Hawkerhurricane

by stephendowdy in Models


Which version of Blender?

The model was created using Blender 2.92 but should work fine with any version above 2.8.

Which render engine?

The model was created for Cycles but uses PRB materials so the texture maps should work with any render engine that supports the PRB metallic workflow.

Published over 2 years ago
Blender Version 2.8, 2.81, 2.82, 2.83, 2.9, 2.91, 2.92, 2.93
License Royalty Free
Have questions before purchasing?

Contact the Creator with your questions right now.

Login to Message