Daft Punk Helmets

by Anton Lanskoy in Models

What versions of Blender is the model compatible with?

Blender provides forward and backward compatibility between versions.

I'm sure the model will work in versions 2.8x - 2.9x and earlier.